This is not the latest version of Linkerd!
This documentation is for an older version of Linkerd. You may want the Linkerd 2.11 (current) documentation instead.

HTTP, HTTP/2, and gRPC Proxying

Linkerd can proxy all TCP connections, and will automatically enable advanced features (including metrics, load balancing, retries, and more) for HTTP, HTTP/2, and gRPC connections. (See TCP Proxying and Protocol Detection for details of how this detection happens).

Notes

  • gRPC applications that use grpc-go must use version 1.3 or later due to a bug in earlier versions.
  • gRPC applications that use @grpc/grpc-js must use version 1.1.0 or later due to a bug in earlier versions.